[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: BerkeleyDB versions

--On August 15, 2007 8:44:41 PM +0300 Kari Mattsson <kari@trivore.com> wrote:


Am I the only one noticing this:

The recommended/optimal Berkeley DB 4.2.52 for OpenLDAP 2.3.x might not
even be supported with the next major release 2.4.x.

I've been reading this thread and know about the background on this, but

Right. The point is, that 4.6 makes an incompatible change with 4.2.52. On the upside, we've only stayed with recommending 4.2 because neither 4.4 or 4.5 did better. 4.6 does do better. I've already discussed with Howard that once the changes for 4.6 are in HEAD, I'll do further benchmarking to compare HEAD w/4.2 support and HEAD w/ 4.6 support to verify that 4.6 continues to give the better performance.



Quanah Gibson-Mount
Principal Software Engineer
Zimbra, Inc
Zimbra ::  the leader in open source messaging and collaboration