[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: BerkeleyDB versions

Quanah Gibson-Mount wrote:

--On August 15, 2007 5:53:04 PM +0200 Hallvard B Furuseth <h.b.furuseth@usit.uio.no> wrote:

Howard Chu writes:
If support for 4.2 is dropped in the next 2.4 beta, what is the earliest
version we think we will support?

We already disallow use of 4.3 due to its instability, so 4.4 would be the minimum.

What's the best BerkeleyDB version to use with OpenLDAP 2.3 anyway?

From my testing, currently it is 4.2.52+patches. However, testing with the
pre-releases from Sleepycat of 4.6 indicated it was faster than 4.2.52 across the board. Both 4.4 and 4.5 come in slower than 4.2 and 4.6 in my testing. So from a throughput (read & write) standpoint, 4.2 is what I've found to be the "best" until 4.6 came along.


Am I the only one noticing this:

The recommended/optimal Berkeley DB 4.2.52 for OpenLDAP 2.3.x might not even be supported with the next major release 2.4.x.

I've been reading this thread and know about the background on this, but still..


//Kari Mattsson