[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Migrating from slapd 2.3 to 2.4


Is this a bug in the version I'm using?

It would be horrible if I had to go re-build all the software that came with my distro.

I've got it working, I think, with the old config file and need to finish moving my other services over before I tackle this problem again.  Maybe when I upgrade the new box to the new new box, the migration will work.  

One comment on the migration and I dont mean to be rude but changing config like this is a huge problem for admins that have to configure http/smtp/http/smb/Nfs/nis/Ldap/dns etc.  I don't mean to come off as a whiner, but if all of these servoices changed their config like ldap, every other release or so, we would all be doomed.  Kinda reminds me of how Microsoft changes their admin model every release.  

Thanks for your help!


On May 21, 2012, at 12:52 PM, Quanah Gibson-Mount <quanah@zimbra.com> wrote:

> --On Monday, May 21, 2012 12:44 PM -0400 Bobby Krupczak <rdk@krupczak.org> wrote:
>> Hi!
>>> > Are there any docs you can point me to on this?  The ones I've found
>>> > via google have not helped me handle any of these exceptions.
>>> What version of OpenLDAP 2.4 are you using? You failed to state this
>>> anywhere that I can see.
>> Sorry.  Its 2.4 but thats not very specific.  On F16,
>> 2.4.26-7.fc16.x86_64 is what is installed.
>> My TLS/SSL primitives also do not port over to the new config.
> a) Use a newer build, don't use distro crap
> b) You'll need to give more information once you've ported using a current version of OpenLDAP.  My TLS directives all port over just fine.
> --Quanah
> --
> Quanah Gibson-Mount
> Sr. Member of Technical Staff
> Zimbra, Inc
> A Division of VMware, Inc.
> --------------------
> Zimbra ::  the leader in open source messaging and collaboration