[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: ldap update ( 2.2 to 2.4)

On 01/17/13 17:10 -0200, Bruno Furtado wrote:
On Fri, Jan 11, 2013 at 6:09 PM, Dan White <dwhite@olp.net> wrote:
On 01/11/13 17:29 -0200, Bruno Furtado wrote:
On Thu, Jan 10, 2013 at 12:34 PM, Dan White <dwhite@olp.net> wrote:
On 01/10/13 12:04 -0200, Bruno Furtado wrote:
Hi Folks!

I'm newbie to LDAP and I received a mission to update the version.

Today is running Openldap 2.2.23 and I need to update to OpenLDAP
2.4.28.  all update attempts failed. I observed that the new version
have a different method of configuration.

What the best way to do this?

What error messages did you receive?

You can use slaptest (with both -f and -F options) to convert your
configuration to the newer configuration database format (see man
slapd-config), although you can still use a slapd.conf based

I tried both settings.

This is the error message:

       50f066f8 str2entry: invalid value for attributeType objectClass #1

This error means that you have a value within your input, for an
objectClass, which is invalid per rfc2252 and is not accepted by the
newer version of slapd that you are using.

Try to found out which entry in your input is causing the error.

Now when I try to start LDAP I get this error:

config error processing olcDatabase={1}bdb,cn=config

olcDatabase={1}bdb.ldif aparently is ok!

What is the output of:

slapcat -n0 -s olcDatabase={1}bdb,cn=config

(remove any passwords or sensitive information)

Increase your debug level to see if you get any more specific information.

Dan White