[Date Prev][Date Next]
Re: just curious
--On Wednesday, April 22, 2009 7:17 AM -0400 William Jojo <email@example.com>
What is the minimum level of BDB required to support OpenLDAP > 2.4.11?
As you know, the change log for 2.4.12 says it added support for BDB
4.7.x and removed pre-BDB 4.4 which is very helpful. Should this be read
as >= 4.4 is acceptable? Looking through the docs, changes and FAQomatic,
I cannot find a definitive list of acceptable/required levels (which
could include, OpenSSL, GnuTLS, SASL, etc). I was wondering if that list
is somewhere I simply can't find. :-)
I'm running BDB 4.6.x with 2.4 and it seems fine for the tests I've done.
I'd be happy to contribute to the docs as I am sure the OpenLDAP team is
swamped with other work. :-)
Did you read the README file shipped with OpenLDAP? I believe it addresses
Building OpenLDAP Software requires a number of software packages
to be preinstalled. Additional information regarding prerequisite
software can be found in the OpenLDAP Administrator's Guide.
Base system (libraries and tools):
Standard C compiler (required)
Cyrus SASL 2.1.21+ (recommended)
OpenSSL 0.9.7+ (recommended)
Reentrant POSIX REGEX software (required)
BDB and HDB backends require Oracle Berkeley DB 4.4, 4.5,
4.6, or 4.7. It is highly recommended to apply the patches
from Oracle for a given release.
Depends on package. See per package README.
Principal Software Engineer
Zimbra :: the leader in open source messaging and collaboration