[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: just curious

Quanah Gibson-Mount wrote:
--On Tuesday, April 21, 2009 9:11 PM +0200 Piotr Wadas <pwadas@dtpw.pl> wrote:

Hello, I've been trying past weeks upgrading my production openldap
software. I started from 2.4.11 when it was available, through all
available versions, up to 2.4.16. I tried package builds, and my own
builds. Each version except 2.4.10 was likely to hang, as it's
production, and load is quite high, I haven't too much patience to debug and researching what's actually going on, but I tried disabling syncrepl
(no  effect), some different settings for bdb backend and slapd thread,
concurrency etc ( starting from settings which caused no problems with
2.4.10 ), and finally, got back to 2.4.10 which works fine. Between
version change I noticed that 2.4.11+ is build with newer libdb versions

No. Only 2.4.12+ requires the higher BDB versions. 2.4.11 and previous have the same BDB requirements.

What is the minimum level of BDB required to support OpenLDAP > 2.4.11?

As you know, the change log for 2.4.12 says it added support for BDB 4.7.x and removed pre-BDB 4.4 which is very helpful. Should this be read as >= 4.4 is acceptable? Looking through the docs, changes and FAQomatic, I cannot find a definitive list of acceptable/required levels (which could include, OpenSSL, GnuTLS, SASL, etc). I was wondering if that list is somewhere I simply can't find. :-)

I'm running BDB 4.6.x with 2.4 and it seems fine for the tests I've done.

I'd be happy to contribute to the docs as I am sure the OpenLDAP team is swamped with other work. :-)




Quanah Gibson-Mount
Principal Software Engineer
Zimbra, Inc
Zimbra ::  the leader in open source messaging and collaboration