[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Migrating from 2.0.21 to 2.3.19 on Fedora 5

Dennis Misc wrote:
I just wanted to be clear.. So it's worse off in having an outdated master,
than having an outdated slave. I've also browsed through the faq-o-matic,
and there doesn't seem to be a replication guide between different versions
of OpenLDAP. (specifically *2.0.21 to 2.3.19*).

If I somehow missed it, please let me know if you happen to have a link/copy
of the docs.


>Since the 2.0 system is the master and the 2.3 is the slave,
>isn't it possible this would be a non-issue?

Then have a worse issue.  The master won't generate
all the operational attributes required by the slave.

- Kurt

As noted here http://www.openldap.org/lists/openldap-software/200604/msg00134.html OpenLDAP 2.3.20 and newer will generate the missing operational attributes, so it will accept replication from any previous version.

 -- Howard Chu
 Chief Architect, Symas Corp.  http://www.symas.com
 Director, Highland Sun        http://highlandsun.com/hyc
 OpenLDAP Core Team            http://www.openldap.org/project/