[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: slapd/bdb stability problem

On Thursday 02 June 2005 21:55, Dieter Kluenter wrote:

> Yes there is a DB_CONFIG file, but to my understanding the reason is,
> that openldap has been build with pth while BerkleyDB has been build
> with libpthread.

Yes, there was a problem with the openpkg build, but it should be fixed 
now. We use native threads if possible, but it should not be a problem 
to use pth, should it? (as long as all libs use the same thread model 
of course!)

> > Also, OpenLDAP-2.2.23 is a little old now (2.2.26 is the current
> > stable release).
> Well, Kolab is based on OpenPKG and they haven't released 2.2.26 yet.

If it would solve the problems, I would be happy to live with the 
openldap-2.2.26 package from openpkg-current.

Steffen Hansen          |       Klarälvdalens Datakonsult AB
Senior Software Engineer|       http://www.klaralvdalens-datakonsult.se
                        |       Platform-independent
                        |       software solutions