[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: LDAP client (2.1.30) with gnuTLS (1.0.16) dies in glibc mutex

Hi Matthijs,
Hi Quanah,

The OpenLDAP in Sarge is already at 2.2.23, so how is it possible that
you have 2.1.30 installed. I know 2.1.30 was the first version that
should be shipped with Sarge, but to do with some critical bugs they
have moved to 2.2.23.

Thank you for this hint. You're right that there is now openldap2.2 source in Sarge, and this will help to put my server back into package based systems.

For the client issues it is thus probably the best strategy to wait some time, because all program packages are still linked with 2.1.30 and somebody told me that the lbldap flavours are not compatible at their API. But I think they will gradually remove the old LDAP from the distribution tree within the next couple of months.

So I'll drop SSL mail client support until then; it seems to be the only service affected.

BTW: The system type is a small enterprise systems, which is maintained by people with small computer knowledge and even smaller time, i.e. I set up a base configuration, which should run itself for the very most of cases.

- lars.