[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: LDAP client (2.1.30) with gnuTLS (1.0.16) dies in glibc mutex

Hi Lars,

On Friday 27 May 2005 10:23, Lars Hanke wrote:
> For the client issues it is thus probably the best strategy to wait some
> time, because all program packages are still linked with 2.1.30 and
> somebody told me that the lbldap flavours are not compatible at their
> API. But I think they will gradually remove the old LDAP from the
> distribution tree within the next couple of months.
> So I'll drop SSL mail client support until then; it seems to be the only
> service affected.
> BTW: The system type is a small enterprise systems, which is maintained
> by people with small computer knowledge and even smaller time, i.e. I
> set up a base configuration, which should run itself for the very most
> of cases.

what you can do is replace the official Debian openldap2 packages by 
those you have compiled yourself with OpenSSL instead of gnuTLS.

Maybe this solves the gnuTLS problem.

If you are interested I can send you my patches as a starting point

Peter Marschall
eMail: peter@adpm.de