[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: --with-threads=pth

At 09:11 AM 10/25/99 -0700, Brett G. Lemoine wrote:
>> We have native support for GNU Pth implemented in devel.  This
>> has yet be ported to 1.2.
>So, without some serious mucking about, I'm not going to be able
>to use Pth in 1.2.7 on a solaris box?

Apparently so.

>> > or is pth something that really isn't recommended?
>> It's recommended on those systems where GNU Pth can provide
>> working Pthread emulation.
>Is solaris known to be such a system?

No.  GNU Pth (or others) cannot easily provide alternative pthread
implementations (or emulation) on Solaris 7 due to problems
with system headers.

>What I'm hoping for is diffs/config options that'll get me started on
>compiling openldap 1.2.7 with GNU's Pth.

It's hoped that someone will port our native GNU Pth support from
devel to 1.2 soon.


Kurt D. Zeilenga		<kurt@boolean.net>
Net Boolean Incorporated	<http://www.boolean.net/>