[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: BerkeleyDB versions

On Tuesday 14 August 2007 17:39:20 Howard Chu wrote:
> Gavin Henry wrote:
> > <quote who="Howard Chu">
> >
> >> Pierangelo Masarati wrote:
> >>> Howard Chu wrote:
> >>>> Our early tests with DB 4.6.1 thru 4.6.3 showed impressive performance
> >>>> gains, making it seem worthwhile. But we have no way of knowing how
> >>>> the current 4.6.18 will perform at the moment.


> > If support for 4.2 is dropped in the next 2.4 beta, what is the earliest
> > version we think we will support?
> We already disallow use of 4.3 due to its instability, so 4.4 would be the
> minimum.
> Also the BDB support guys at Oracle are now saying they'd like 4.2 to be
> dropped anyway, as it's nearing its 4th birthday, and they don't want to
> have to deal with it any more. I guess that's reasonable...

Most distros that have db4.2 with all the recommended patches already have a 
4.4 or later. On distros that don't ... you'd probably be bundling a version 
of Berkely DB anyway, it might as well give performance benefits as well

(while trying to finish up db4.6 packages for Mandriva ...)