[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: 2.4.13 update troubles

--On Wednesday, December 10, 2008 4:27 PM +0000 Emmanuel Dreyfus <manu@netbsd.org> wrote:

On Wed, Dec 10, 2008 at 08:05:48AM -0800, Quanah Gibson-Mount wrote:
What BDB release are you using?  OpenLDAP 2.4.13 no longer supports BDB
4.2.52, for example, which is what I believe Ubuntu was using.

I am running: OpenLDAP-2.4.11 db-4.6.21 cyrus-sasl-2.1.22 NetBSD-4.0_STABLE

I had a bad time with:
OpenLDAP-2.4.13 db- cyrus-sasl-2.1.22 NetBSD-4.0_STABLE

There's two patches for BDB 4.7.25. One from Oracle's official site, and one from Oracle that they won't release for some inane reason. If you don't have them both applied, it will not work right. Look in the build/ directory that comes with OpenLDAP 2.4.12 or later.



Quanah Gibson-Mount
Principal Software Engineer
Zimbra, Inc
Zimbra ::  the leader in open source messaging and collaboration