[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Unable to locat TLS libs - help needed

On Monday, 25 June 2007, Jon Roberts wrote:
> Aviator LDap wrote:
> > I am struggling with a very basic error. While running the configure
> > script of OpenLDAP 2.3.33, I am getting the following Warning message
> >
> > *configure: WARNING: Could not locate TLS/SSL package
> > configure: WARNING: TLS data protection not supported!*
> > **
> If you definitely want TLS, you can run configure with the --with-tls
> option. That way configure will fail instead of just giving you a warning.
> > Can anybody help me to locat what could be going wrong. I am executing
> > the script in Suse Linux.
> > I am totally struck with this.
> Look closely in the config.log file generated by configure to see where
> the failure occurs. Lines that begin with "Checking for..." are of
> interest when followed by lines about failures.
> Finally, I'll mention that last week I was getting a failure that looked
> the same up to what you describe.

No, yours was different, the headers had been located, but configure could not 
link to the library.

In this case, it looks like the headers were not found.

The OP should ensure that the relevant software is installed. For example, 
most linux distributions ship the headers and development libraries in 
separate packages. So, for example, the 'openssl-devel' package should be 

However, this *really* isn't an OpenLDAP-specific issue. IMHO, people with 
generic problems compiling the software (e.g. any time configure fails) 
should really consult a list appropriate to their OS/distribtion.


Buchan Milne
ISP Systems Specialist - Monitoring/Authentication Team Leader

Attachment: pgpSSk0BHFx2z.pgp
Description: PGP signature