[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: hints for troubleshooting Replication problems

On Sun, 25 Jun 2006 13:03:34 -0700
Quanah Gibson-Mount <quanah@stanford.edu> wrote:

> --On Sunday, June 25, 2006 6:49 PM +0200 Pavlos Parissis 
> <p_pavlos@freemail.gr> wrote:
> > Do you have any hints how I can troubleshoot the issue and spot the
> > problem?
> The problem is that you are using an ancient version of OpenLDAP
> which only had LDBM as the backend, and it is likely corrupting
> itself.  You should really look at upgrading to a modern, supported
> release of OpenLDAP.
> --Quanah

I agree with you that the old version of OL could be the root cause of my problems.
But, I need to make sure that is the case and not something else.
Imagine the scenario of upgrading and still have the same problem.

I believe that the only way to avoid the mentioned scenario is to find technical evidences which
support what you are saying. I suppose that you say that because you have seen similar problems
and the cause of them was the LDBM backend.

Thus, I asked about hints which could help me to find these evidences and make a proposal to my Managers
for upgrading to the latest version.

Since, you are mentioning about corruption, I can easily see that using db_verify and say
if the problem is coming from the corruption of the DB files.

Then, I need to find out what is causing the corruption and as you say the LDBM backend is a candidate for this.

Do you have any ITS which point to that issue?
So far I have found only ITS3421 which could be related to my issue.