[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: DB_PRIVATE Error OpenLDAP 2.3.20 (src) and DB4-4.2.52 (rpm)

--On Monday, April 03, 2006 1:15 PM +0800 Patrick Clohessy <pat@cs.curtin.edu.au> wrote:

Hi All

Just a quick query about openldap 2.3.20 (src) and db 4.2.52 (rpm), I'm
getting the "Berkeley DB library configured to support only DB_PRIVATE
environments" error.

I know how to fix the error by using db 4.2.52 from source because this
doesn't get compiled with support for POSIX threading which seems to be
the cause of the problem.

Now I also have openldap 2.2.17 (src) running on the same server and it
works fine with both db 4.2.52 (rpm) and db 4.2.52 (src), how come 2.3.20
breaks with the db rpm?

It might be related to the fact that OL 2.3.20 uses cursors whereas 2.2 does not.


Quanah Gibson-Mount
Principal Software Developer
ITS/Shared Application Services
Stanford University
GnuPG Public Key: http://www.stanford.edu/~quanah/pgp.html