[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: DB_PRIVATE Error OpenLDAP 2.3.20 (src) and DB4-4.2.52 (rpm)

Patrick Clohessy wrote:
Hi All

Just a quick query about openldap 2.3.20 (src) and db 4.2.52 (rpm), I'm getting the "Berkeley DB library configured to support only DB_PRIVATE environments" error.

I know how to fix the error by using db 4.2.52 from source because this doesn't get compiled with support for POSIX threading which seems to be the cause of the problem.

Now I also have openldap 2.2.17 (src) running on the same server and it works fine with both db 4.2.52 (rpm) and db 4.2.52 (src), how come 2.3.20 breaks with the db rpm?

One thing I've noticed is that libdb is dynamically linked to slapd in 2.2.17 and not 2.3.20.

Ah, that makes sense. There's a bug in the libtool script bundled with OpenLDAP 2.3 that makes it link libdb statically instead of dynamically. I patched this back in release 2.3.12 but the patch was overwritten in release 2.3.15 when Kurt imported libtool 1.5.20 into CVS. I believe the libtool maintainers finally integrated the patch in 1.5.21, we should probably update our copy again. Perhaps you should file an ITS report for this issue so it doesn't fall through the cracks again.

 -- Howard Chu
 Chief Architect, Symas Corp.  http://www.symas.com
 Director, Highland Sun        http://highlandsun.com/hyc
 OpenLDAP Core Team            http://www.openldap.org/project/