[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Password encryption (crypt) incompatibility

--On Tuesday, March 21, 2006 10:23 AM +0100 Smoltok <Smoltok@wanadoo.fr> wrote:


I have configured and installed a replica on an OpenLDAP 2.3.4 with
--enable-crypt option.
The master is on another place on an OpenLDAP 2.2.x.

The synchronization is correct but we have a problem with password.

I can't connect in command line or in java with an user DN and password
to my server. ( "invalid credential" ).
If i created a password on my own server with slappasswd and insert it
into my entry and it works.

So is it possible that between version 2.2.x and 2.3.4 there is such an
incompatibility ?

Maybe the problem is somewhere else...

Why are you using OpenLDAP 2.3.4? There were many issues in the early OpenLDAP 2.3 releases. I highly advise upgrading to 2.3.20.


Quanah Gibson-Mount
Principal Software Developer
ITS/Shared Application Services
Stanford University
GnuPG Public Key: http://www.stanford.edu/~quanah/pgp.html