[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Slurpd replication 2.0->2.2 problem

Quoting John Morris <openldap@butchwax.com>:

> Huh, so then there's no way to upgrade from 2.0->2.2 on a live network
> of openldap servers.  Luckily, our LDAP system is not often written to
> at the moment.

Quoting Samuel Tran <stran@amnh.org>:

> We are also in the process of migrating from OpenLDAP 2.0.x to 2.2.x.

Well, I upgraded a couple of months ago (4-5?) and I had to write a script
that 'converted' my 2.0 database (LDIF) to something a 2.2 server understands.

It's very my-site centric, but with perl knowledge (and some trial and errors :),
you might get it to work for you...