[Date Prev][Date Next] [Chronological] [Thread] [Top]

RE: configure: error: Berkeley DB version mismatch

I have tried 2.2.13 (many times) and 2.2.15 (just once) on Solaris8
without issue.

Could u provide the following details for maillist users to help u:

1) full command line of "./configure" including arguments and
environment setting prefixes
2) assuming u r using /bin/sh, output of "set" to show $PATH,
$LD_LIBRARY_PATH and others, assuming u did not overwrite them in
"./configure" using "env" prefix
3) partial config.log showing the errors
4) what version of gcc are u using? (gcc -v)
5) output of "which ld" and "which make"


-----Original Message-----
From: owner-openldap-software@OpenLDAP.org
[mailto:owner-openldap-software@OpenLDAP.org] On Behalf Of Cameron Gregg
Sent: Wednesday, September 15, 2004 4:41 PM
To: OpenLDAP Software List
Subject: Re: configure: error: Berkeley DB version mismatch

> It looks to me like it couldn't find any matching library.
> I had a problem like this with OpenLDAP 2.2.15 under Solaris, but it
> hasn't shown up so far in 2.2.17.  Usually it found the library 
> correctly running configure a second time under Solaris.
> --Quanah

I tried using 2.2.17, still the same error ;-/