[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: configure: error: Berkeley DB version mismatch

Tay, Gary wrote:

I have tried 2.2.13 (many times) and 2.2.15 (just once) on Solaris8
without issue.

Could u provide the following details for maillist users to help u:

Here they all are, I hope you can make something of it.

1) full command line of "./configure" including arguments and environment setting prefixes

./configure --prefix=/usr/local/openldap --with-tls --enable-crypt --enable-bdb

2) assuming u r using /bin/sh, output of "set" to show $PATH,
$LD_LIBRARY_PATH and others, assuming u did not overwrite them in
"./configure" using "env" prefix

# echo $LDFLAGS
-L/usr/local/ssl/lib -L/usr/local/BerkeleyDB.4.2/lib -L/usr/local/cyrus-sasl/lib
# echo $CPPFLAGS
-I/usr/local/ssl/include -I/usr/local/BerkeleyDB.4.2/include -I/usr/local/cyrus-sasl/include
# echo $PATH

# crle

Configuration file [3]: /var/ld/ld.config
  Default Library Path (ELF):   /usr/lib:/usr/local/lib
  Trusted Directories (ELF):    /usr/lib/secure  (system default)

Command line:
  crle -c /var/ld/ld.config -l /usr/lib:/usr/local/lib


// I usually try not to set this, I've heard it's bad???

3) partial config.log showing the errors

# tail config.log if( major != DB_VERSION_MAJOR || minor < DB_VERSION_MINOR ) { printf("Berkeley DB version mismatch\n" "\texpected: %s\n\tgot: %s\n", DB_VERSION_STRING, version); return 1; } #endif

return 0;

// I posted the full config.log in another post in this thread.

4) what version of gcc are u using? (gcc -v)

# gcc -v
Reading specs from /usr/local/lib/gcc-lib/sparc-sun-solaris2.8/3.3.2/specs
Configured with: ../configure --with-as=/usr/ccs/bin/as --with-ld=/usr/ccs/bin/ld --disable-nls
Thread model: posix
gcc version 3.3.2

5) output of "which ld" and "which make"

# which ld /usr/ccs/bin/ld # which make /usr/local/bin/make #

Rgds Gary

any help??