[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Problem with ldapsearch

On Thursday 05 February 2004 11:38, Lara Adianto wrote:
> Thanks for your reply Howard.
> As you suggested, I looked at my config.log file, but
> I'm still not too sure how to solve my problem
> though...Do you have any suggestions ?
> Anyway, I've tried to configure the server without the
> sasl and tsl/ssl...like this:
> $ ./configure --enable-debug, --without-cyrus-sasl
> --without-kerberos --without-tls --enable-crypt
> --enable-passwd --enable-wrappers --enable-ldbm
> but I still encountered the same problem with
> ldapsearch...
> Do you have any suggestion on how to configure
> properly? In most books and website, it is written
> that ./configure (without having to specify each
> option) will work just fine since it will
> automatically detect the appropriate settings.
> However, in my case, it will complain about mismatch
> version of SASL
> This is the extraction of my
> /tests/db-test/master.log:
> daemon_init: 1 listener opened
> slapd_init: initiated server
> slap_sasl_init: SASL version mismatch, got 201000a,
> wanted 2010011

the line above shows the problem.

You compiled OpenLDAP against cyrus-sasl 2.1.17 (= 2010011) but during the 
tests the dynamic linker finds only cyrus-sasl 2.1.10 (= 2010011).

The dynamic linker needs to know the location of cyrus-sasl 2.1.17
and load the cyrus 2.1.17 libs instead of the 2.1.10 libs

The man pages for ld.so, ldconfig an ldd may help you to make the dynamic 
linker aware of the locateion of the cyrus 2.1.17 libs.

Peter Marschall
eMail: peter@adpm.de