[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: BerkeleyDB

Check if BDB4.0 is not installed.
If your OS is RH (8.0 ?), check "rpm -qa '*db*'.

Check libdb-4.1.so (BDB-4.1)and libdb-4.0.so (BDB-4.0).

2 differents versions of BDB must not be installed on the same system.

When you build OpenLDAP, export BDB libs and include in CPPFLAGS and LDFLAGS.

export CPPFLAGS='-I/path/to/BDB/include'
export LDFLAGS='-L/path/to/BDB/lib'

./configure ****



Quoting Jerad Hampton <jerad.hampton@kingsu.ca>:

> Good day,
> When I run the configure on openldap-2.1.17 I get this error:
> configure:error DDB: BerkeleyDB version incompatible
> I currently have DB-4.1.24 installed and I have tried .25 and got the same
> error.
> Is there a preferred version that I should use.  If so where can I get that
> version
> Thanks
> Jerad Hampton
> Network Administrator
> The King's University College

Mail sent through GFI Mailserver1.0
info: ava@gfi.be