[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: segmentation fault since V2.1.16

A 18:15 17/04/2003 +0200, Tony Earnshaw a écrit :
>tor, 17.04.2003 kl. 16.32 skrev Vincent MATHIEU:
>> I can't migrate to openLDAP 2.1.16 (nor 2.1.17) (with dbBerkeley 4.1.25 and openssl 0.9.7a).
>> I have a segmentation fault with slapd (and slapadd, ....) with 4 servers openLDAP.
>In addition to Pierangelo's advice/request:
>In your latest request you don't state your OS/distro.
>I'm running all you detail for yourself, without seg. faults. I /have/
>had seg. faults on the same machine and same OS/distro - RH 7.2+++++ -
>and they have invariably been through compiles using mixed libraries.
>I.e., both BDB 4.0 and 4.1 together, or Openssl 0.9.6 and 0.9.7
>together, at the same time.
>Do an ldd on the respective binaries to check that this isn't happening
>on your system.
>To each his own poison, but 2.1.17/BDB 4.1.25 on my test/production rig
>is the basis of almost all authentication services I use and is utterly
>stable and reliable, irrespective of system load.

I have the problem in redhat 7.3
It work's a little better in redhat 7.2 : if I disactive the monitor, it work's!

in 2.1.17 (doesn' work)
ldd /usr/local/openldap-2.1.17/libexec/slapd
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x40014000)
        libssl.so.0.9.7 => /usr/local/OpenSSL/lib/libssl.so.0.9.7 (0x40042000)
        libcrypto.so.0.9.7 => /usr/local/OpenSSL/lib/libcrypto.so.0.9.7 (0x40070000)
        libresolv.so.2 => /lib/libresolv.so.2 (0x40161000)
        libdl.so.2 => /lib/libdl.so.2 (0x40172000)
        libpthread.so.0 => /lib/i686/libpthread.so.0 (0x40175000)
        libc.so.6 => /lib/i686/libc.so.6 (0x42000000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

in 2.1.11 (works)
ldd /usr/local/openldap-2.1.11/libexec/slapd
        libdb-4.0.so => /usr/lib/libdb-4.0.so (0x40014000)
        libssl.so.0.9.6 => /usr/lib/libssl.so.0.9.6 (0x4009a000)
        libcrypto.so.0.9.6 => /usr/lib/libcrypto.so.0.9.6 (0x400c8000)
        libresolv.so.2 => /lib/libresolv.so.2 (0x40185000)
        libdl.so.2 => /lib/libdl.so.2 (0x40196000)
        libpthread.so.0 => /lib/i686/libpthread.so.0 (0x40199000)
        libc.so.6 => /lib/i686/libc.so.6 (0x42000000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000) 

I have the libcrypt.so.1 more in 2.1.17 (LDFLAG=-lcrypt in configure, otherwise the crypt password doesn't work).