[Date Prev][Date Next] [Chronological] [Thread] [Top]

RE: Application Error in slapd.exe on W2000

OpenLDAP still supports Cyrus 1.5.x. The version requirement is that if
you are using Cyrus 2.1.y, y must be greater than 2, as older versions
of 2.1.y are too broken. 1.5.24 is also pretty broken though; you
should probably be using at least 1.5.27 and preferably 1.5.28.

  -- Howard Chu
  Chief Architect, Symas Corp.       Director, Highland Sun
  http://www.symas.com               http://highlandsun.com/hyc
  Symas: Premier OpenSource Development and Support 

> -----Original Message-----
> From: owner-openldap-software@OpenLDAP.org
> [mailto:owner-openldap-software@OpenLDAP.org]On Behalf Of Kervin L.
> Pierre
> Do you have a debug build you can use?  Can you reproduce the error on a 
>   machine with a debugger?  You may need to run the debug build in MSVC 
> to get a stacktrace.
> OpenLDAP no longer supports Cyrus 1.x builds, IIRC.  Please correct me 
> if I'm work someone.  OpenLDAP configure complains about all but recent 
> versions of SASL and some intermittant crashes I came across were 
> attributed to the SASL library, even if I only used '-x'.  If you don't 
> need the SASL, try building without it.
> I have a similar config as you that seems to work ok.
> berkeley 4.0.14, OpenSSL 0.9.6d, back-perl with active state perl 5.6.1.
> Those binaries are here.
> http://prdownloads.sf.net/acctsync/openldap-binaries-2.1.3-16JUL02.zip
> See if those crash as well.  You need activestate perl binaries to run 
> these though, as they are linked against perl56.dll ( I need back-perl )
> --Kervin
> Geert Van Muylem wrote:
> > Hi,
> > 
> > I've build OpenLDAP 2.1.3 on a W2K system based on
> > - Berkeley DB 4.0.14
> > - Cyrus SASL 1.5.24
> > - OpenSSL 0.9.6d (TLS enabled)
> > - HS regex-lib