[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Problem with SQL Backend

do you have any ODBC manager installed on your system? The problem could be in that back-sql module failed to load ODBC library...
As for 2.0.23, it may well be that it's configure was not updated/tested to build back-sql, because it is kinda paused. There are too much things left to do in back-sql to make it up to date (applying several patches, unicode support etc), but I still cannot get to it... So if you want to use back-sql with later versions - you will have to review configure scripts and other possible missynchronized places yourself.
WBW, Dmitry
----- Original Message -----
Sent: Tuesday, February 26, 2002 8:31 PM
Subject: Problem with SQL Backend

I installed Mandrake 8.1 recently and it comes with OpenLDAP 2.0.14
I am having troubles starting LDAP with the SQL Backend... The LDAP service starts just fine with every other module but when i try to load the SQL module in the
slapd.conf it just fails to start the service.

Does anyone had this kind of trouble before?
The logs aren't much helpfull... if i don't load the module they say "SQL database unknown", if i load the module they just say "slapd start failed".

I tryed also installing the source of OpenLDAP 2.0.23 with the ./configure --enable-sql=yes but i had the same kind of problem.
With ./configure --with-module-sql it gave me an error installing wich i don't remember, but it was something like "invalid option set to yes"

Any help on this matter would be apreciated.
If i am posting to the wrong list, my apologies. From the website it seemed the most correct list to post this kind of troubles.


Nuno Branco

Markdata - Informação para Gestão, Lda.
R. Padre Luís Aparício, n.º 10 - 3º
1150 - 248 Lisboa