[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: ACL evaluation on ADD operations (ITS#4556)

Hallvard B Furuseth wrote:
Howard Chu writes:
I'm leaning toward add_attr_acl but not too thrilled with that. It's hard to
come up with a meaningful name that doesn't get overly verbose. Any other

Is this a per-database on/off option defaulting from a global setting, or just a global "on if included" option?

It's a per-DB boolean, yes. Default is off. (Except for cn=config, which will default on.)

Nitpick, but I would call it "access<something>" so it sorts next to

Currently I'm using 'add_content_acl' and add* sorts next to "access"... -- -- Howard Chu CTO, Symas Corp. http://www.symas.com Director, Highland Sun http://highlandsun.com/hyc/ Chief Architect, OpenLDAP http://www.openldap.org/project/