[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: ACL evaluation on ADD operations (ITS#4556)

Hallvard B Furuseth wrote:
Howard Chu writes:
I'm leaning toward add_attr_acl but not too thrilled with that. It's hard to come up with a meaningful name that doesn't get overly verbose. Any other suggestions?

Is this a per-database on/off option defaulting from a global setting, or just a global "on if included" option?

Nitpick, but I would call it "access<something>" so it sorts next to

"access_check_attrs_on_add" ?

Yes, per-database would be nice. It'd probably cost a char in the BackendDB structure, or would a bit in be_flags suffice?


Ing. Pierangelo Masarati OpenLDAP Core Team

SysNet s.r.l.
via Dossi, 8 - 27100 Pavia - ITALIA
Office:  +39 02 23998309
Mobile:  +39 333 4963172
Fax:     +39 0382 476497
Email:   ando@sys-net.it