[Date Prev][Date Next] [Chronological] [Thread] [Top]

RE: saslAuthz{To|From}

>> -----Original Message-----
>> From: owner-openldap-devel@OpenLDAP.org
>> [mailto:owner-openldap-devel@OpenLDAP.org]On Behalf Of Pierangelo
>> Masarati
>> >> How about calling the directive "authid-rewrite"?
>> >> (since we use it for more than SASL.)
> Kinda implies that saslauthz.c should have "sasl" removed from its
> names...

??? I was a bit disturbed by the overuse of the SASL naming
(yes, including ldap_sasl_bind()) because I ended up using
the sasl-regexp stuff and more even when doing non-SASL
auth.  In this sense, saslAuthz{To|From} should look like
auth{To|From}.  Now I'm happy with it (I'm using SASL also
for other projects, e.g. MBDyn and RTAI in future releases)
because in some sense SASL is __THE__ auth approach the LDAP
protocol uses, so for LDAP (and for many other protocolos)
it is a synonym of AUTH.


>   -- Howard Chu
>   Chief Architect, Symas Corp.       Director, Highland Sun
>   http://www.symas.com               http://highlandsun.com/hyc
>   Symas: Premier OpenSource Development and Support

Pierangelo Masarati