[Date Prev][Date Next] [Chronological] [Thread] [Top]

RE: saslAuthz{To|From}

>> How about calling the directive "authid-rewrite"?
>> (since we use it for more than SASL.)
> To ease the writing while reusing the rewrite parser
> as is, I was thinking about doing sasl-rewrite*, e.g.
> sasl-rewriteContex saslRegexp
> sasl-rewriteRule ".*" "%0" ":"
> ando so on; with the prefix you suggest:
> authid-rewriteContex authid
> authid-rewriteRule ".*" "%0" ":"
> and so; comments?

The patch is in


now diferent rules are invoked to map authcid or authzid,
if the info is available; it also mimics the old behavior if

sasl-regexp <match> <replace>

is given instead of a set of

authid-rewrite<statement> <arg> [...]

I'll post an ITS for this ...


Pierangelo Masarati