[Date Prev][Date Next] [Chronological] [Thread] [Top]

RE: Protocol: attribute selection

You've simply replaced 'election' with 'electors'. How can this help? Also, to preserve alignment with X.500, I think you should retain the word 'selection' for the SEQUENCE.

-----Original Message-----
From: owner-ietf-ldapbis@OpenLDAP.org
[mailto:owner-ietf-ldapbis@OpenLDAP.org]On Behalf Of Kurt D. Zeilenga
Sent: Tuesday, 16 March 2004 08:33
To: Hallvard B Furuseth
Cc: ietf-ldapbis@OpenLDAP.org
Subject: Re: Protocol: attribute selection

At 01:09 PM 3/15/2004, Hallvard B Furuseth wrote:
>I think an earlier message about this may have gotten lost:
>In [protocol]-22 4.5.1 (Search Request),
>the ASN.1 list of attributes has the confusing names
>        AttributeSelection ::= SEQUENCE OF selection LDAPString 
>                -- constrained to <attributeSelection> below 
>so in plain language, the attributes are a selection of a selection.

Seems it would be better:
        AttributeSelectors ::= SEQUENCE of selector LDAPString
                -- selector constrained to <attributeSelector>



>Also, it is selection and not AttributeSelection which is constrained to
><attributeSelection>, which is the syntax for _one_ attribute:
>     attributeSelection = attributedescription / selectionspecial 
>So an AttributeSelection is a sequence of attributeSelections...
>I suggest to call the ABNF token and the 'selection' ASN.1 name
>'requestedAttribute', 'searchAttr' or something.