[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Problem in sync-repling multiple databases

Hi Quanah,

On Mon, Oct 29, 2012 at 6:16 PM, Quanah Gibson-Mount <quanah@zimbra.com> wrote:
--On Monday, October 29, 2012 8:52 AM +0100 Marco Pizzoli <marco.pizzoli@gmail.com> wrote:

If I try to configure a second replica configration targeted directly to
(in example) to ou=ou3, then that ou get replicated.
Any help/advice is welcome.

Hi Marco,

You have not provided any useful information with which to help you, so there is not really any advice one can offer you.  I.e., you have not provided the configuration you are using on your master and replicas in the scenario where you have multiple DBs.
You are absolutely right and I'm aware of it...
The problem is in this case I can't provide any (even similar to)real configuration. Both from technical limitation (remote server with no possibility of copy/paste) and corporate policy*.
I was hoping to find a known logical problem/bug, so to continue myself.
I read an answer from Howard to another user some times ago telling him that is a known problem in OL2.3 not handling well subordinate db's and syncrepl, so I asked from help in this topic.
The suggestion (from another user) was, for that release, to configure a syncrepl directive for each of the subordinate db's. This is what I did and in the end I succeded in syncrepling also other db's.
If you have general guidance, know issues to share in cases similar to these and so on... I would be interested in it.
Thanks for your comprehension
* Continuing experimenting I found also 2 or 3 cases in which I'm able to crash OL 2.4.33 (in one case by simply slapadding using back-mdb) but I CAN'T provide any material to file a "valid" ITS. I'm sorry about that.



Quanah Gibson-Mount
Sr. Member of Technical Staff
Zimbra, Inc
A Division of VMware, Inc.
Zimbra ::  the leader in open source messaging and collaboration