[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: PANIC: bdb fatal region

--On Wednesday, March 16, 2011 3:12 PM -0600 ldap@mm.st wrote:

I am rebuilding our aging pre 2.2 openldap servers that ran  ldbm
backend and slurpd.  We ran this setup without any issues for many

The new setup is:
openldap 2.3.43 (Stock RH)
bdb backend 4.4.20 (Stock RH)

I highly advise you to build your own OpenLDAP and BDB packages. 2.3 is no longer a supported release series. The current stable release is 2.4.23.

Otherwise, you should be directing these issues to the company who provided you these packages, namely RedHat.

Personally, I used OpenLDAP 2.3.43 with BDB 4.2.52+patches for years without issue (using delta-sync for replication).

It is entirely possible the BDB build provided by RedHat is missing critical patches.



Quanah Gibson-Mount
Sr. Member of Technical Staff
Zimbra, Inc
A Division of VMware, Inc.
Zimbra ::  the leader in open source messaging and collaboration