[Date Prev][Date Next] [Chronological] [Thread] [Top]

Unable to install OpenLdap in GNU/Linux

I am trying to install OpenLDAP in GNU/Linux:

 uname -a
Linux jupnms1 2.6.18-164.el5 #1 SMP Thu Sep 3 03:28:30 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

I downloaded openldap version 2.4.23 
I also installed BerkelyDB version 5.1.19 . Since the location of this db is not the default I set the proper environment variables for configure to find it:
LDFLAGS=-L/usr/local/lib -L/usr/local/BerkeleyDB.5.1/lib
CPPFLAGS=-I/usr/local/include -I/usr/local/BerkeleyDB.5.1/include

Additionally, I have updated the link to db.h to propperly point to the new Berkely DB:
/usr/include/db.h -> /usr/local/BerkeleyDB.5.1/include/db.h because it was pointing to an old one.

However after all these changes I still get an error. 

The command I ran is:
./configure --prefix /opt/COTS/ldap

The results is attached.

I really appretiate your help on this matter. I am currently evaluating different options for Authentication/Authorization data storage and have never worked with LDAP. LDAP is being proposed as the prefered way to store this data, however I need to prototype some solutions to present to management.


Attachment: configure.log
Description: configure.log