[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: error while adding entry using ldap.jar JAVA API

--On Friday, April 11, 2008 9:47 AM +0200 Michael StrÃder <michael@stroeder.com> wrote:

Aaron Richton wrote:
On Thu, 10 Apr 2008, Sumith Narayanan wrote:

Ok.. So which is the latest stable version .. OpenLDAP and BDB ?
Thanks, Sumith

The latest RE23 is 2.3.41. Most people find a patched BDB 4.2.52 to be the gold standard, but there are some possibly relevant bugs that are fixed in a patched 4.6.21.

This statement can be misleading for running OpenLDAP 2.3.x since BDB 4.6.x can only be used with OpenLDAP 2.4.x.

I think the point was, there has been a recent patch to BDB 4.6.21, and the issue that patch fixes looks like it is present in all 4.2->4.5 releases. On the other hand, I don't believe anyone has hit the issue it fixes in the years folks have been running 4.2+. So maybe OpenLDAP doesn't exercise the problematic code path. Or perhaps something about 4.6 itself made it more likely to trigger.



Quanah Gibson-Mount
Principal Software Engineer
Zimbra, Inc
Zimbra ::  the leader in open source messaging and collaboration