[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Upgrading blues

--On Thursday, January 24, 2008 4:07 PM +0800 Sn!per <sniper@home.net.my> wrote:

Am currently running openldap-2.3.35 against BerkeleyDB version 4.5.20.
Saw that there are now the stable openLDAP version 2.3.39  and also the
Berkeley DB version 4.6.21.

I used openLDAP to power my qmail-ldap and wonder if I really need to
upgrade at all. If the answer is yes, then with openLDAP version 2.3.39,
would it be recommended to go for the latest Berkeley DB's version of
should I stay with my current 4.5.20 ? I have read (was it this list?)
somewhere that there were some incompatibilities issues between some
version of openLDAP and Berkeley DB.

Please advise and thank you in advance.

OpenLDAP 2.3 does not support BDB 4.6. If you want to use BDB 4.6, you must use the OpenLDAP 2.4 branch.



Quanah Gibson-Mount
Principal Software Engineer
Zimbra, Inc
Zimbra ::  the leader in open source messaging and collaboration