[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Error at make : libdb-4.3.so: could not read symbols: File in wrong format

--On Monday, February 19, 2007 3:12 PM -0500 matthew sporleder <msporleder@gmail.com> wrote:

Openldap only wants to use BDB 4.2.52 or 4.4. (or 4.6, when it comes
out)  I would recommend building a BDB exclusively for openldap use
and just putting in its own directory.
(/usr/local/openldap-2.3.33/include comes to mind)

Or BDB 4.5, there's nothing wrong with it, either. BDB 4.3 is simply a known bad release, and I still find people who are using it, and end up with all sorts of odd and broken behavior because of it. I just helped someone 2 days ago whose entire system went down because BDB 4.3's database corrupts and won't auto recover.


Quanah Gibson-Mount
Principal Software Developer
ITS/Shared Application Services
Stanford University
GnuPG Public Key: http://www.stanford.edu/~quanah/pgp.html