[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: [ldap] Re: Announce: Net-LDAPapi version 2.00 released

On Fri Feb 09 2007 at 11:18:32 CET, Howard Chu wrote:

> Quanah Gibson-Mount wrote:
> >A new release of Net::LDAPapi module is now available for Perl via CPAN. 
> >This release includes compilation against OpenLDAP libraries from 
> >version 2.1 forward.  It now supports LDAPv3, including SASL binds.
> Great, glad to see this finally making it back out to the world.

So am I: as you have also noted below, it is much faster than Net::LDAP.

> ><http://search.cpan.org/~mishikal/Net-LDAPapi-2.00/>

It appears to use deprecated calls to OpenLDAP. Defining LDAP_DEPRECATED
as 0 or 1 has no effect for me. A `make test' produces

Can't load 'blib/arch/auto/Net/LDAPapi/LDAPapi.so' for module \
    Net::LDAPapi: blib/arch/auto/Net/LDAPapi/LDAPapi.so: undefined symbol:\
    ldap_value_free at /usr/lib/perl5/5.8.5/i386-linux-thread-multi/DynaLoader.pm \
    line 230.  at test.pl line 11

What am I doing wrong?