[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: openldap-2.3.19 fails test020-proxycache

I would start from tests/testrun/slapd.*.log...

Filippo Mesirca wrote:

I've got a slackware-10.2 updated to slackware-current (gcc libraries version 3.4.5).
I compiled openldap-2.3.19 package passing the following options to ./configure

export CFLAGS="-O2 -march=$arch -mtune=$cpu"
export CXXFLAGS="-O2 -march=$arch -mtune=$cpu"
./configure \
  --prefix=/usr \
  --sysconfdir=/etc \
  --localstatedir=/var \
  --disable-debug \
  --enable-dynamic \
  --enable-syslog \
  --enable-ipv6 \
  --enable-slapd \
  --enable-cleartext \
  --enable-crypt \
  --enable-modules \
  --enable-rlookups \
  --enable-wrappers \
  --enable-bdb \
  --enable-dnssrv \
  --enable-hdb \
  --enable-ldap \
  --enable-ldbm \
  --enable-meta \
  --enable-monitor \
  --enable-null \
  --enable-passwd \
  --enable-perl \
  --enable-relay \
  --enable-overlays \
  --enable-slurpd \
  --with-threads \
  --with-tls \
  --enable-dyngroup \
  --enable-dynlist \
  --enable-ppolicy \
  --enable-valsort \
  --program-prefix="" \

I issued a "make depend" and a "make -j2"... the package compiled cleanly, without problems. To see if the build was correct, I issued a "make test": it blocks in making test020-proxycache..... I ran manually all the other following tests: the only test that failed is the 20th... Here is the output:

root@macinino:~/packages/source/openldap/openldap-2.3.19/tests# ./run test020
Cleaning up test run directory leftover from previous run.
Running ./scripts/test020-proxycache...
Starting master slapd on TCP/IP port 9011...
Using ldapsearch to check that master slapd is running...
Using ldapadd to populate the master directory...
Starting proxy cache on TCP/IP port 9012...
Using ldapsearch to check that proxy slapd is running...
Making queries on the proxy cache...
Query 1: filter:(sn=Jon) attrs:all
Query 2: filter:(|(cn=*Jon*)(sn=Jon*)) attrs:cn sn title uid
Query 3: filter:(sn=Smith*) attrs: cn sn uid
Query 4: filter:(sn=Doe*) attrs: cn sn title uid
Query5: filter:(uid=bjorn) attrs: mail postaladdress telephonenumber cn uid
Query6: filter:(mail=*@mail.alumni.example.com) cn sn title uid
Query 7: filter: (mail=*) cn sn title uid
Error in verifying cacheability

Has anyone any idea of what's happening? I have no idea to where to start searching for the problem...

Thank you very much in advance for your help.


Ing. Luca Scamoni
Responsabile Ricerca e Sviluppo

SysNet s.n.c.
Via Dossi, 8 - 27100 Pavia - ITALIA
Office:     +39.0382.573859 (137)
Mobile:     +39.347.1014425
Email:      luca.scamoni@sys-net.it