[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: OpenLDAP configuration issue

My Example:
install bdb 4.2.52 + patches  in /usr/local/db-4.2.52

then run next command in shell:

LDFLAGS="-L/usr/local/db-4.2.52/lib -Wl,-R/usr/local/db-4.2.52/lib"
./configure --enable-crypt --prefix=/usr/local/openldap

NOTE: In linux mechine, you must specify "-Wl,-Ryour_db_lib_path" in
the LDFLAGS environment.  I think Faq-O-Matic should add the point but
only solaris's section include some hints....

2005/12/6, Manish Marathe <mumarathe@gmail.com>:
> Hello,
> Thanks for  your help in advance.
> I am building and installing OpenLDAP 2.2.27. At the configuration step, I
> am getting en error:
> "configure: error: BDB/HDB: BerkeleyDB version incompatible"
> The version which OpenLDAP is looking for right now is the system installed
> version. I am  installing the recent version of Berkeley DB  on my Red Hat
> machine in /opt/dev. For the configuration option for openldap I am giving
> --with-bdb=/opt/dev as the path, but the error is still coming.
> Can anyone let me know how can I let OpenLDAP know the path of new version
> of Berkeley DB.
> Thanks
> --
> Manish Marathe
> SpikeSource, Inc.
> http://developer.spikesource.com