[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: "User Schema Load failed ...", using ppolicy.schema overlay

Robert Kupperstein wrote:
I've tried that, with no luck.

BTW, I'm working with 2.3.11, but I have the same
problem with 2.3.7 and 2.3.9.

This was written up as a bug, but w/o any mention of
how to work around it:

That bug was fixed long ago, before 2.3 was ever released. Make sure you're using the correct version of the ppolicy.schema file to match the ppolicy.c code.
static ppolicy overlay init (ITS#3137)

    * To: openldap-its@OpenLDAP.org
    * Subject: static ppolicy overlay init (ITS#3137)
    * From: pierangelo.masarati@sys-net.it
    * Date: Sat, 8 May 2004 22:33:54 GMT

Full_Name: Pierangelo Masarati
Version: HEAD (2.2?)
OS: Linux (irrelevant)
URL: ftp://ftp.openldap.org/incoming/
Submission from: (NULL) (

If the ppolicy overlay is statically built into slapd, ppolicy_init() fails complaining about "User Schema Load failed..."; there is no way to aviod this, not even loading ppolicy.schema also when the overlay is not used, because overlay initialization occurs before configuration is read.


--- Buchan Milne <bgmilne@staff.telkomsa.net> wrote:

On Thursday 27 October 2005 20:13, Robert
Kupperstein wrote:
Can someone tell me how to work around this
Should I use different configure options to build
dynamically loadable version? What options do I
to use?
I think the solution to this is to add an include
line for the ppolicy.schema file distributed with OpenLDAP to your slapd.conf.


Buchan Milne
ISP Systems Specialist

 -- Howard Chu
 Chief Architect, Symas Corp.  http://www.symas.com
 Director, Highland Sun        http://highlandsun.com/hyc
 OpenLDAP Core Team            http://www.openldap.org/project/