[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: "User Schema Load failed ...", using ppolicy.schema overlay

I've tried that, with no luck.

BTW, I'm working with 2.3.11, but I have the same
problem with 2.3.7 and 2.3.9.

This was written up as a bug, but w/o any mention of
how to work around it:

static ppolicy overlay init (ITS#3137)

    * To: openldap-its@OpenLDAP.org
    * Subject: static ppolicy overlay init (ITS#3137)
    * From: pierangelo.masarati@sys-net.it
    * Date: Sat, 8 May 2004 22:33:54 GMT

Full_Name: Pierangelo Masarati
Version: HEAD (2.2?)
OS: Linux (irrelevant)
URL: ftp://ftp.openldap.org/incoming/
Submission from: (NULL) (

If the ppolicy overlay is statically built into slapd,
ppolicy_init() fails
complaining about "User Schema Load failed..."; there
is no way to aviod this,
not even loading ppolicy.schema also when the overlay
is not used, because
overlay initialization occurs before configuration is


--- Buchan Milne <bgmilne@staff.telkomsa.net> wrote:

> On Thursday 27 October 2005 20:13, Robert
> Kupperstein wrote:
> > Can someone tell me how to work around this
> problem?
> >
> > Should I use different configure options to build
> a
> > dynamically loadable version?  What options do I
> need
> > to use?
> I think the solution to this is to add an include
> line for the ppolicy.schema 
> file distributed with OpenLDAP to your slapd.conf.
> Regards,
> Buchan
> -- 
> Buchan Milne
> ISP Systems Specialist
> B.Eng,RHCE(803004789010797),LPIC-2(LPI000074592)

Yahoo! Mail - PC Magazine Editors' Choice 2005 

Yahoo! FareChase: Search multiple travel sites in one click.