[Date Prev][Date Next] [Chronological] [Thread] [Top]

Urgent Please Help: Credentials Cache?


I looked up the openldap archives, but have found no answer to this query. So, I am reposting.

The problem is that when I use DIGEST-MD5 binding with openldap, for a particular user say - 'user1', then the first time it works; then if I use 'user1' again, it fails and says 'Invalid Credentials'. I checked the userid and password, which is being sent correctly.
To get rid of this problem, I have to log in as a second user (say 'user2'), and then if I use 'user1' again, it works.
This suggests that some kind of caching is happening either at the Openldap or at SASL level.
How can I turn off this caching?

Please help!!
(Please also see the earlier post below).

From: "Pankaj Mathur" <agentman97@hotmail.com>
To: OpenLDAP-software@OpenLDAP.org
Subject: DIGEST-MD5 issues  in ldap_sasl_interactive_bind_s
Date: Fri, 26 Aug 2005 00:52:54 +0000


I am using ldap_sasl_interactive_bind_s in the following way in a function (which consists of just the code below):

void* defaults = NULL; int rc = 0; defaults = lutil_sasl_defaults( ld, (char*)mechanism, NULL, (char*) dn, cred->bv_val, NULL );

rc= ldap_sasl_interactive_bind_s( ld, (char*) dn, (char*) mechanism, NULL, NULL,
LDAP_SASL_AUTOMATIC, lutil_sasl_interact, defaults );

				lutil_sasl_freedefs( defaults );

When using DIGEST-MD5, it works fine for the first time within a process, however when calling it again in a separate LDAP connection, it returns "Invalid Credentials".
Is there a problem in the code?

Any help is appreciated.


NRIs, does your family in India need money? http://creative.mediaturf.net/creatives/icicibank/ICICI_NRI_ERA.htm Open an ICICI Bank NRI savings A/c

A Mobile Phone sells every 16 minutes on eBay.in? http://adfarm.mediaplex.com/ad/ck/4686-26272-10936-558?ck=Mobiles Get Your Model Now!