[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: syncrepl w/ 2.3 and bdb 4.3 working great

I was having problem with syncrepl ( 2.3 and bdb 4.3 ).  some of the entries didn't go to the slave and sometimes, old entries were gone too..

do you mind share your configuration ( both master and slave )?



Dusty Doris <openldap@mail.doris.cc>
Sent by: owner-openldap-software@OpenLDAP.org

08/12/2005 12:07 PM

syncrepl w/ 2.3 and bdb 4.3 working great

Just thought I'd let you all know that I'm doing some testing on
openldap2.3 (from rel_eng_2_3 cvs 8/11 about 1PM) w/ BDB 4.3 and so far
things are going pretty good.

My test so far was the following.

-slapadd about 400,000 entries to the master server, with about 3-4
attributes per entry.
-slapcat the master
-add a few more entries to master
-slapadd -q -w the slaves (this takes about 90 seconds!) and turn them up
-verify contextcsn is updated correctly and the replication starts at the
new entries added after original slapcat
-run script on master to test replication
-add 5000 more users (1-5000)
-remove users 3000-5000
-add users 3000-8000
-remove 1-8000
-add 1-9000
*ran that in a single ldapadd command
-ldapsearch on all 409,000 users (uid=*) on each server > file.servername
-diff the ldapsearch files to look for any errors in replication

The replication was almost immediate to the two slave servers.  At the end
the contextCSN's were all correct.  A diff on the search on each server
showed that all the entries were the same and complete.

This is just a preliminary test and only did add/remove (no mods), but
thought I would let people know that so far I'm not seeing any issues on
this limited test.

I'll be out of town for a week, when I get back I'd like to do some more
heavy testing.

Anyone have any advice on specific things to look for that they've run
into issues with using BDB 4.3 on 2.3?

-Dusty Doris