[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: R: slapd process needs a restart

--On Wednesday, January 26, 2005 12:22 PM +0100 "Roberto Balducci (Proconsul)" <roberto.balducci@proconsul-it.it> wrote:


thanks for your email.

We're thinking of upgrading both products, but we would like to know if
we have to consider other things:

- we have developed a client using openldap api: do we have to update
something or just recompile?

I'm not sure on this one.

- do the actual bdb files are compatible with new openldap and Berkley
db release?

No, you will need to slapcat the database and then slapadd it when changing the BDB version. Also, there are changes to how ACL's work between OL 2.1 and 2.2 that you probably want to test if you move from 2.1 to 2.2.

It isn't a straightforward move, but it is one that should result in a more reliable and speedy server.


Quanah Gibson-Mount
Principal Software Developer
ITSS/Shared Services
Stanford University
GnuPG Public Key: http://www.stanford.edu/~quanah/pgp.html

"These censorship operations against schools and libraries are stronger
than ever in the present religio-political climate. They often focus on
fantasy and sf books, which foster that deadly enemy to bigotry and blind
faith, the imagination." -- Ursula K. Le Guin