[Date Prev][Date Next] [Chronological] [Thread] [Top]

RE: Multiple syncrepl problems

Good day,

> > I would love to give 2.2.20 or even a CVS copy (wouldn't be 
> the first
> > time) a go, if I could find out why no entries are being 
> replicated with
> > it.  Do those error messages make any sense to anyone?
> >
> > Thanks also for your advice on syncrepl.
> In 2.3.0 alpha I'm having an issue where new entries are not 
> replicated 
> unless I stop and start all replica's.  MOD's are never 
> replicated (see 
> ITS#3470).

The problem with 2.2.20 was that NO entries would get replicated if I
started up a fresh consumer- the consumer would just start up and spam
syslog with those "null_callback : error code 0x32" entries.  If it helps
any, here's what the database dir looks like:

-r--r--r--  1 root root   137 Nov  4 15:19 DB_CONFIG
-rw-------  1 ldap ldap  8192 Jan  7 10:45 dn2id.bdb
-rw-------  1 ldap ldap 32768 Jan  7 10:45 id2entry.bdb
-rw-------  1 ldap ldap 43007 Jan  7 10:45 log.0000000001

(this is after a log file cleanup with a slapd_db_recover, which is run upon
slapd shutdown)
I guess I can set up another machine to be a 2.2.20 test provider and see
what happens, although perhaps some developers would be interested to find
out WHY this doesn't work.

We have had many other problems with modifies not showing up, though...

Thanks again for your time,

Darren Gamble
Planner, Regional Services
Shaw Cablesystems GP
630 - 3rd Avenue SW
Calgary, Alberta, Canada
T2P 4L4
(403) 781-4948