[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: problem with db_stat

--On Sunday, December 19, 2004 10:37 AM +0100 vadim <vadim.tarassov@swissonline.ch> wrote:

Hallo everybody,

I am not sure that this message is relevant for this list, however still
may be interesting.

When I was adding entries to LDAP server (2.2.19) with bdb backend
(BerkeleyDB-4.3.21.NC) using ldapadd, I have issued db_stat -m command
to see what happens to my cache. As result, ldapadd crashed with error
message similar to "internal error", and db_stat produced following:

You are asking for trouble by running BDB 4.3.21. I argued against its support being included in 2.2.19, and I advise you to move to BDB 4.2.52 (plus patches). BDB 4.3.21 has a variety of bugs, and I'd wait until they release newer versions and patch sets before using it.


-- Quanah Gibson-Mount Principal Software Developer ITSS/Shared Services Stanford University GnuPG Public Key: http://www.stanford.edu/~quanah/pgp.html