[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: [Repost] JDNI Authentication

The OS is Fedora Core 2 and I'm using OpenLDAP 2.2.17. The difference between the two boxes is the OS version Red Hat 9 verus Fedora and 2.1 OpenLdap on the older box.

Actually, If I do an ldapsearch for cn=user, it works fine. I am not sure what to use to replicate the the lookup that JNDI is using. I thought there might be something telling and obvious that I was missing in the trace or in the config files... If there is another type of search I can do to try to replicate the issue, please let me know and I'll run it. Anyone out there using Java/JDNI?


Kurt D. Zeilenga wrote:

At 04:12 PM 10/11/2004, Ross Rankin wrote:

Sorry for the repost but I'm still having the same issue and am unable to resolve it... Let me know if there is a better group to post this in...

Reposting without providing additional information is kind of pointless.

You should work on reducing your problem to one which
can be duplication using OpenLDAP command line tools.
You shouldn't presume folks here understand the
non-OpenLDAP Software you are using.

You also provide more details, such as the version of
OpenLDAP Software being used (on both systems).  As you
say, if you have the same configuration in both places,
then something else must be different.  You should try
to figure out what's different.



I am using JNDI and Tomcat for authentication. This is a new server I am setting up to replace an exisiting one... Upgraded hardware / software... Anyway, authentication works for the user but doesn't find the user in the group... It doesn't make sense, since this same config works on another box. Here's the necessary files:
debug log: