[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Problem during installation

Indeed, it's an LD_LIBRARY_PATH problem while compiling conftest !
But why does it worked fine in 2.2.14 an then fails since 2.2.15 ?? sorry I haven't take the time to "diff" the configure script from 2.2.14 and 2.2.15 on that BDB test part ...
If someone knows the difference, what happened ... ? please let us know .

tkalyan b wrote:

The configure script actually compiles and runs a
small conftest program to check for berkeley db
When LD_LIBRARY_PATH is not set it throws an error
saying configure: error: Berkeley DB version mismatch
But what really has happened is while running conftest
it encountered becuase of not having the right
./conftest: error while loading shared libraries:
libdb-4.2.so: cannot open shared object file: No such
file or directory

So the final error message seems to be bit misleading.
Even the config.log shows only the failed program  as
standard error for conftest is redirected /dev/null.

configure:19292: cc -o conftest -g -O2
-I/opt/db/include -L/opt/db/lib conftest.c -ldb-4.2 -pthread -lresolv 1>&5
configure: failed program was:
#line 19259 "configure"
#include "confdefs.h"
etc. etc.


--- Jehan PROCACCIA <Jehan.Procaccia@int-evry.fr>

I've already mentioned that problem a few weeks ago
... here's a short workaround, but below I repost my question which
had'nt been answered ...
short solution:

export LD_LIBRARY_PATH=path_of_bdb_libs

My previous post:


I'am building my own relocatable RPM package of
openldap 2.2.15, and I noticed that the configure script couldn't anymore
check the BDB package version . Indeed my package (as Redhat/Fedora
packages do ) include it's own version on BDB (4.2.52) to keep beeing system
indepedent about BDB version.
Everything worked fined before (in 2.2.14 at least
!) but since 2.2.15 I concluded that the conftest binary needs to be told
where is the embeded BDB libraries, in short I added LD_LIBRARY_PATH=../db-4.2.52/build-rpm/.libs/ before
running "test -s conftest${ac_exeext} && (./conftest; exit)
2>/dev/null" at line 19291 in configure script .
If not, configure ended with :
configure: error: Berkeley DB version mismatch

What changes between 2.2.14 and 2.2.15 causes this
to happen ? is it normal or there's an error in 2.2.15 configure
script ?
Here's the patch I applied:

$ cat


diff -ur openldap-2.2.15.old/configure
--- openldap-2.2.15.old/configure 2004-07-27
18:33:12.000000000 +0200
+++ openldap-2.2.15/configure 2004-08-05
15:32:28.371610872 +0200
@@ -19288,10 +19288,14 @@
return 0;
+echo jehan $LD_LIBRARY_PATH 1>&5
if { (eval echo configure:19292: \"$ac_link\") 1>&5;
(eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} &&
(./conftest; exit) 2>/dev/null
+echo "jehan then" >&5
+echo "jehan else" >&5
echo "configure: failed program was:" >&5
cat conftest.$ac_ext >&5
rm -fr conftest*

With that patch it now builds correclty and my
relocatable package works fine ( I will send an other mail about the
ditribution of that package ...)


Olivier PAYRE wrote:


I'm trying to install OpenLDAP (the last version !

2.4) on my computer

(Mandrake 10.0). BerkeleyDB 4.2.52 is installed in


My command to configure OpenLDAP (before make) is :

env CPPFLAGS="-I/usr/local/ssl/include
-I/usr/local/BerkeleyDB.4.2/include "


-L/usr/local/BerkeleyDB.4.2/lib " ./configure


--enable-spasswd --enable-rewrite --enable-ldap


--enable-passwd –enable-slurpd

and the message is :

	configure: error: Berkeley DB version mismatch
I don't know what to do ...

PAYRE Olivier
CSIE - France

Do you Yahoo!?
Declare Yourself - Register online to vote today!