[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: ldapdb broken with sasl-2.1.19?

paul k <paul@subsignal.org> writes:

> Hi,
> I can't get ldapdb plugin to work with sasl-2.1.19. It compiles fine
> and the resulting libldapdb.so.2.1.19 looks sane. The error on slapd
> startup is:
> platform is linux 2.4.25, db-4.2+patches, openldap-2.2.15,
> heimdal-0.6.2. Any ideas how to track this down further?

IMO it is openldap-2.2.15 which causes trouble with ldapdb. I run
cyrus-sasl-2.1.18 and 2.1.19 with patched ldapdb, which works fine with
openldap-2.2.12 through to openldap-2.2.14 but lead to a slapd freeze
with openldap-2.2.15.

Dieter Klünter | Systemberatung
Tel.: +49.40.64861967
Fax : +49.40.64891521